header YouTube
Clonk Livestream auf Twitch.tv!

Clonkspot

Windows 10 Creators Update und DirectX

#1

Unter genannter Windows 10-Version scheint Clonk Rage (Vollbild-Modus) zumindest bei mir nicht mehr zu starten, beim Ausführen beendet das Programm sich sofort.

Es wurde eine Neuinstallation versucht sowie das Nutzen des Kompatibilitätsmodus von Windows (W7, W8) als auch das Starten mit Adminrechten.

Hat da jemand ähnliche Erfahrungen?

0 Likes

#2

Was steht denn in der Clonk.log?

0 Likes

#3

[22:21:05] Command line:
[22:21:05]
[22:21:05] Clonk Rage
[22:21:05] Version: 4.9.10.7 [330]  win32
[22:21:05] Registered to:
[22:21:05] Display mode not supported
[22:21:05]   CreateDevice failure.
[22:21:05] FATALER FEHLER: Fehler bei DirectDraw. Bitte DirectX-Installation auf diesem System prüfen. Dazu im Windows-Startmenü unter Ausführen 'dxdiag.exe' eingeben. Es muss mindestens DirectX Version 8.1 installiert sein.
[22:21:05] Spiel deinitialisiert.
[22:21:05] Engine heruntergefahren.


Vorhanden ist DX12.

Sofern DirectX durch das Windows Update ebenfalls ein Update erfahren hat würde es das Problem erklären, demnach hat Clonk Rage entweder ein Problem mit DirectX oder mit irgendwas vom Creators Update.
Meh, ist die Frage was man da machen kann, evtl. ältere directX-Komponenten in den Clonk-Ordner beifügen, ähnlich wie es manche Spiele mit Grafiktreiber-Komponenten machen? xD

0 Likes

#4

Versuch mal die Einstellungen zu löschen: Editor.exe schließen (falls offen), dann Eingabeaufforderung starten und
reg delete "HKCU\Software\RedWolf Design\Clonk Rage"
ausführen. Wenn das auch nicht hilft, dann teste mal ob wenigstens der Fenstermodus funktioniert:
reg add "HKCU\Software\RedWolf Design\Clonk Rage\Graphics" /v NewGfxCfg /t REG_DWORD /d 1024 /f

0 Likes

#5

Ausgezeichnet, danke!

Die gespeicherten Einstellungen in der Registry zu entfernen hilft nicht, ein kurzer Test, indem man den entsprechenden Ordner einfach unbenennt, zeigt, das die .exe weiterhin direkt schließt (aber davor einen neuen Standardordner in der Registry anlegt).

Aber das Nachtragen des Fenstermodus' lässt das Spiel wieder wie gewohnt starten, sodass das Creators Update (oder das darin oder kurz zuvor gemachte DirectX-Update) da kein Problem darstellt.

Man sollte aber beachten das die Standard-Installation von Clonk Rage in Zukunft nicht mehr unter Windows funktioniert, auch mit Kompatibilitätsmodi nicht.
Ein Update in der Richtung ist denke ich mal nicht zu erwarten, wobei es zumindest schön wäre, den Fenstermodus als Option nachzureichen und bei der Installation standardmäßig zu aktivieren, um das Problem zu umgehen, wenn man es schon nicht lösen wird.
Naja, oder man hängt irgendwo einen Hinweistext hin falls man man auf clonk.de was runterlädt xD

0 Likes

#6

Mh kann man den Fenstermodus noch irgendwie borderless bekommen? Leider spielt man nicht mit voller Bildschirmauflösung was je nach Spielinhalten unglücklich ist, beispielsweise bei Objekten mit pixelgenauen Grafiken, wo dann gerne mal ein 1-pixel-breites Objekt dann einfach im Fenstermodus unsichtbar ist.

[Edit]
Standardmäßig ist es borderless, aber wenn Clonk für einen Moment hängt, beispielsweise um ein aufwendigeres Szenario mit multiplen Objektpaketen zu laden, wird das Fenster von Windows dann zu einem normalen Vollbildfenster umgewandelt wo man die Ränder sieht, was ein leicht komprimiertes Bild verursacht.

0 Likes

#7

Unter Windows hab ich deshalb immer die Auflösung in der Registry so angepasst, dass ich genau die Dicke von Taskleiste und Fensterrahmen abgezogen hab.
Dann bei Clonkstart einmal maximieren (Win+Pfeil Hoch oder sowas?) und dann passte es.

0 Likes

#8

Hast du zufällig 1920x1080? Und wenn nicht, kannst du kurz schauen wie viel Pixel du jeweils für ResolutionX und ResolutionY aufgerechnet hast? Davon ausgehend das du die selben Fensterrahmen hast xD

Das scheint aber nicht zu funktionieren, beim Maximieren richtet Windows das Fenster automatisch auf die Bildschirmränder aus, sodass die Ränder einerseits wieder im Bild zu sehen sind, und andererseits das eigentliche Spiel in diesem Fenster reinkomprimiert wird was zu Darstellungsverzerrungen führt =/

0 Likes

#9

Ja ich hab 1920x1080, aber ich hab kein Windows mehr.

Unter Windows 7 dürfte es sowas bei 1920x1018 oder so gewesen sein (kann mich nicht mehr wirklich erinnern :x).

Ich hab damals vom maximierten einen Screenshot gemacht und dann mit GIMP abgemessen.
Zuerst manuell maximieren damit die Ränder eben da sind.

0 Likes

#10

Hatte testweise mal das Fenster kleiner und größer als die eigentliche Auflösung geschaltet, aber leider wird bei genanntem Lade-Lag das Fenster wieder auf die eigentliche Auflösung angepasst.

0 Likes

#11

Ich rate einfach mal: Das neueste Update unterstützt DirectX 8 nicht mehr. Versuchen kannst du auch, die Engine auf OpenGL umzustellen. Setze Engine=1 (afaik).

>Der Wert ist in der Registry hinterlegt, im Schlüssel HKEY_CURRENT_USER\Software\RedWolf Design\Clonk Rage\Graphics.

0 Likes

#12

Stimmt, wollte das heute testen und OpenGL funktioniert weiterhin.

Aber dazu muss man ja erstmal in die Einstellungen des Spiels gelangen was bei einer frischen Installation dann ja nicht funktioniert.

Man muss in Zukunft bei Windows also entweder den Fenstermodus aktivieren oder OpenGL bevor man das Spiel überhaupt starten kann - also kein Weg um die Registry herum =P

0 Likes

#13

Per Update DirectX einfach ganz zu deaktivieren sollte doch machbar sein, oder?

0 Likes

#14

Dazu muss es erstmal zu einem Update kommen…
Aber ja, möglich wäre es.

0 Likes

#15

Versuch mal DirectX und das hier.

0 Likes

#16

Nice try aber leider nein, selber Fehler wie oben.

Haben die wohl DirectX9 auch abgeschossen? =P

0 Likes

#17

Blöd an OpenGL ist die merkwürdige Fenster minimieren-Unterstützung:
Minimieren kann man das Fenster scheinbar nicht, und wenn man es anderweitig erzwingt (Alles minimieren-Button in der Taskleiste von Windows), wird das Fenster wieder maximiert, sobald man ein anderes Fenster aktiviert, meh.

Momentan scheint mir die beste Lösung zu sein OpenGL zu nutzen und per Registry 40px von der Y-Fenstergröße abzuziehen.
Auf die Weise sieht man die Windows-Taskleiste (Standardgröße) und kann von da aus jederzeit auf andere Fenster zugreifen und Clonk zumindest temporär per Alles minimieren-Button wegbekommen - auch wird der Fensterrahmen nicht nachträglich wieder eingeblendet wenn Clonk bei Ladevorgängen kurz hängt, sodass das eigentliche Spiel auch nicht unschön visuell komprimiert wird.

Der Vollbildmodus war aber trotzdem besser, da man die Anwendung so wenigstens auch wirklich komplett minimieren konnte und es solange nicht mehr sieht, bis man es wieder aufruft.

0 Likes

#18

Du sollst OpenGL und den Vollbildmodus nutzen :wink:

0 Likes

#19

Habe mal testweise die Einstellungen in der Registry umbenannt, das Spiel einmal abstürzen lassen damit es frische Standardeinstellungen lädt, und habe dann den Engine-Wert auf 1 gesetzt damit ich mit OpenGL starten kann.

Clonk startet dann standardmäßig mit 800x600px in einem randlosen Fenster das, wie beschrieben, nicht minimierbar ist außer per groben 'Alles minimieren'-Befehlen, wobei die Anwendung bei jedweder Aktivierung eines anderen Fensters sich wieder maximiert (zwar hinter dem Fenster das man gewählt hat aber demnach kann man es nicht dauerhaft minimieren, es sei denn man macht nichts mit anderen Fenstern).

In den Optionen wird 'Vollbild' nebenbei angekreuzt und ausgegraut dargestellt.

Kann man in der Registry noch irgendeinen Wert umstellen um Vollbild zu erzwingen?

0 Likes

#20

NewGfxCfg auf 0 setzen.

0 Likes