header YouTube
Clonk Livestream auf Twitch.tv!

Clonkspot

Eingebettete Bilder im Forum

TL;DR: Bitte wenn möglich für Screenshots, die ihr im Forum posten wollt, das “Anhängen”-Feature verwenden.

Das Clonkspot-Forum lebt vom Austausch von Screenshots. Umso frustrierender ist es, wenn beim Nachlesen diese Screenshots irgendwann dann nicht mehr auftauchen. Ich habe mich zwar bemüht, die Screenshots immer möglichst bald hierher zu transferieren, aber das wird schnell mühselig.

Aus diesem Grund werden ab sofort keine Bilder mehr angezeigt, deren Links nicht mit “https” beginnen. Das schließt nicht alle Bildhoster aus (imgur unterstützt z.B. auch https, auch wenn die Links nicht standardmäßig so sind), aber mit hoher Wahrscheinlichkeit alle schlechten. In einigen alten Posts tauchen die Bilder dadurch jetzt nicht mehr auf, bei denen bestand aber sowieso schon die ganze Zeit die Gefahr, dass sie früher oder später verschwinden.

Falls irgendwo sonstige Probleme auftauchen, bitte hier melden!

Hat der User, der das Bild in seinem Kommentar anhängt, für unbegrenzte Zeit Kontrolle oder muss bei Korrektur oder dem Löschen ein Admin angefragt werden?

Du kannst unter "Anhängen" Bilder theoretisch beliebig lange herauslöschen (evtl. nicht mehr, sollte das Topic geschlossen werden). Es geht hier ja nur darum, Hoster zu unterbinden, die nach ein paar Wochen die Bilder wieder löschen.

Find ich gut. Aber man kann immer erst etwas Anhängen, nachdem man einen Post erstellt hat, und nicht bereits während man ihn schreibt. Aber das ist allgemein eher ein Problem von MW Forum, oder?

Ja, das ist leider so. Typischerweise dauert es aber auch ein bisschen, bevor ein frischer Post gelesen wird, daher ist das normalerweise kein Problem. Man muss nur eben schon wissen, wie es funktioniert.

Wie wäre es mit einem allgemeinen Bilderuploader auf Clonkspot, wo man diese Datei per einbinden kann? Hab sowas auch für meinen Chat gebaut.
preg_replace('@[img](.*?)[/img]@is', '<a target="_blank" href="…/uploads/content/$1"><img src="…/uploads/content/$1" /></a>');

Dann könnte die Datei direkt angezeigt werden und zugleich auf Clonkspot liegen. Weil momentan kann ja die Attachment-ID nicht per <img /> dargestellt werden.

Edit: Huch, dass geht ja doch. Aber wie? Es ist ja keine Image-Datei.

Ich weiß nicht, was du mir sagen willst :slight_smile:

Du kannst angehängte Bilder in den Post tun, indem du den Dateinamen des Bilds in den [img]-Tag steckst.

Ah okay… Hab an [ img ]http-Adresse[ /img ] gedacht. Und mit einer .pl?aid=x kann img ja nix anfangen.

Mit Dateinamen ist es dann so wie bei mir. ^^

Wieso sollte eine Bildressource keine URL Parameter nehmen koennen?

Kannst du eine Ausnahme für openclonk.org machen?

Ist jetzt drin für http://*.openclonk.org

Die Ausnahmeregel für Clonkforge ist jetzt draußen, bitte Clonkforge-Bilder mit “https://clonkforge.net/…” verlinken. Fehlt nur noch openclonk.org…!