Clonk Rage won't start.

I played Clonk Rage in 2009 maybe? And i recently found it again and tried installing it. But everytime i open the game nothing happens. If i run as adminestrator the game opens minimized. I click on the game and for a second or two i hear the music play and then i minimizes again. Does anyone know how to fix that if possible? Thanks

Try installing CR outside of the C:\Program Files\ directory, e.g. in C:\Clonk Rage. Clonk has issues with the access control mechanisms in newer Windows versions.

The game opens in minimized by itself now but it still just goes black plays some music and minimizes

Maybe there's an error message in the log file. Look for a "Clonk.log" file in your Clonk installation directory and paste its contents here. (If you can't find one there, it's probably in the AppData directory %APPDATA%\Clonk Rage\ or something like that.)

The Clonk Rage folder is empty and it's not in the other one either. Is there anywhere else it could be?
Edit: Found the file this is what it says

[14:20:42] Command line:
[14:20:42] Clonk Rage
[14:20:42] Version: [330]  win32
[14:20:42] No valid key file found.
[14:20:44] Loading graphics…
[14:20:45] Music: Frontend.ogg
[14:21:00] Game cleared.
[14:21:00] Engine shut down.