Clonk Rage will nicht mehr.

Hallo Leute

dies ist wohl eines der letzten Foren von Clonk die noch "leben".

Mein Problem ist das Clonk Rage (Version 4.9.10.6) nicht mehr startet.
Sobalt ich Clonk starten will, wird mein Bildschirm dunkel und dann richtig schwarz als ob er aus wäre (was er aber nicht ist)
Danach hilft nur noch der Reset Schalter, denn mein PC reagiert einfach nicht mehr.
Das seltsame hierbei ist, das Clonk Rage 2012 noch funktioniert hat und ich keine Hardware gewechselt habe.
Von einen Tag auf den anderen ging es damal nicht mehr. Ich habe schon in dieversen Foren (z.B. Clonk Center, Computerbase)gefragt, aber keiner konnte mir helfen.
!Über den Clonk Editor kann ich die Levels starten! aber so kann man ja nicht wirklich spielen.
So ein Ähnliches Problem hatte ich auch bei Supertux als ich da in den Grafikeinstellungen rumgespielt habe. Der Unterschied da war das ich den Taskmanager aufrufen konnte und bei Clonk klappt nix.

Mein System:
Betriebssystem:   Windows 7 64-bit
Prozessor:          Inter Core i7 2600k
Arbeitsspeicher:  16GB Kingston
Direct X Version: 11
Graka:               NVidia GeForce GTX580
Netzteil:            750Watt

Das hab ich bishher (vergeblich) versucht:
Im Kompatibilitätsfenster bei "Einstellungen" alles mal angehakt,
"Kompatibilitätsmodus" mit Win XP und Vista probiert,
"Programm als Administrator starten" angehakt

Unter "Verknüpfung" ->"Ausführen" -> minimiert ausgewählt (will trotzdem im Vollbildmodus starten)
Grafikkarten Treiber ist aktuell
Alle Windows Updates sind gemacht
Keine Viren, Trojaner usw. gefunden
Support von RedWolf Design gibt es ja scheinbar nicht mehr.

Ich hab das Gefühl das es was mit der Grafikkarte zu tun hat.
Das Irgendwelche Updates im Konflikt mit dem Spiel stehen.
Könnte es sein das Direct 3D was damit zu tun hat? Wenn ja wie kann man das ausschalten?

Ich habe mit Clonk viel Zeit verbracht und ich finde es einfach viel besser als Minecraft,Terraria oder Starbound zusammen.

Über Hilfe wäre ich sehr dankbar

Liebe Grüße

Lord Artis

Hi,

probier als erstes mal eine “saubere Installation” von Clonk, am besten dieses zip-Paket runterladen und in deinem Benutzerordner entpacken; danach die Clonk.exe aus dem Verzeichnis starten.

Sollte es dann nach wie vor nicht klappen, dürfte zumindest eine Clonk.log im selben Verzeichnis angelegt werden. Dort sollten weitere Infos drinstehen.

Viel Erfolg!

Er hat ne .log erstellt, aber da steht nichts interessantes drinne:

[09:12:09] Command line:
[09:12:09]
[09:12:09] Clonk Rage
[09:12:09] Version: 4.9.10.7 [330]  win32
[09:12:09] Registered to: Daniel Berndt (Daniel) [Mein Key hab ich mal rausgenommen :D]

mehr steht da nicht drinn.

Teste mal ob es was bringt, die Clonk-Konfiguration zu löschen (wird dann beim nächsten Start von Clonk neu erstellt): reg delete "HKCU\Software\RedWolf Design\Clonk Rage" /f
Wenn das auch nicht hilft, dann versuche mal den Fenstermodus zu aktivieren: reg add "HKCU\Software\RedWolf Design\Clonk Rage\Graphics" /v NewGfxCfg /t REG_DWORD /d 1024 /f

Vielleicht hast du das gleiche Problem wie hier?

Ansonsten erzähl doch mal deine NVidia Treiberversion und deine Schirmauflösung, dann versuch ich das mal zu reproduzieren, ich habe zufälligerweise auch eine i7 2600k und GTX 580 und Win7 64-bit :slight_smile:

YEAH BABY deine 2te Methode hat funktioniert !!! ich konnte CLONK Wirklich im Fenstermodus starten!!
Du bist mein Held:birthday:
Ich hab in den einstellungen die Auflösung wieder auf 1920x1080 gestellt und siehe da es funktioniert noch IMMER.

Ich konnte deinen weg den du geschrieben hats gerade so folgen ^^ oder hab ich was anderes gemacht?
(Ausführen "regedit" den Pfad herausgesucht dann statt Hexadezimal nur dezimal angepunktet und die 1024 stand schon da)
Das war bestimmt nicht so wie du es gemeint hast hab ich recht? ^^

Aber was war da das Problem?
Das täte mich mal interessieren und wie bist du auf die Lösung gekommen?

Dir dank ich hiermit auchnochmal das du dich bemüht hast einen alten Clonk Spieler glücklich zu machen auch wenn ich bis zu deiner Lösung nicht mehr kam ;D

Das Problem ist das CR probleme hat höhe Auflösungen zu erkennen. Hast du zufällig ein Bildschirm was eine Standardauflösung höher als 1920x1080 hat?

Ne nicht höher aber 1920x1080 ist richtig.

> (Ausführen "regedit" den Pfad herausgesucht dann statt Hexadezimal nur dezimal angepunktet und die 1024 stand schon da)


Das ist nur die Darstellung. Wenn 1024 nach dem Wechsel auf dezimal schon da stand, dann war der Fenstermodus zu dem Zeitpunkt schon aktiviert.

Wie ist das nun mit dem Vollbildmodus? Der ist ja in den Optionen ausgegraut und bei einer Auflösung von 1920x1080 klappt das spielen zwar aber man ist etwas weit "weg".
Wenn ich jetzt die Auflösung herunter setzte wird z.B. 1024x768 ist das für mich genau die richtige auflösung, aber wenn ich das Fenster jetzt Groß mache verpixelt das zusehr.
Hat da noch jemand ein Vorschlag?
Warscheinlich muss ich jetzt wieder alles umgekehrt machen und dann hab ich wieder das Problem :smiley:

Stelle einfach eine Aufloesung ein, die dein Monitor nativ kann, beende Clonk (!), starte Regedit, stelle NewGfxCfg auf 0 und probiere, Clonk wieder zu starten.

Lol moment mal ich bin nicht so der Mega Pro
Soll ich die Bildschirmauflösung vom Desktop runtersetzen oder in Clonk? Nativ ist die niedrigste Auflösung oder wie jetzt?
Die niedrigste Auflösung wäre 800x600

In Clonk

Funktioniert leider nicht, der Bildschrim wird dann wieder schwarz und danach noch schwärzer.

> noch schwärzer.


Schlecht. Welche Aufloesung hast du denn in Clonk ausprobiert? Funktioniert eine von denen, die du kriegst, wenn du "alle Aufloesungen anzeigen" anklickt? Funktioniert ist, wenn du in den Optionen auf OpenGL stellst?

1920x1080
1024x768
1680x1050

Mit OpenGL crasht es nicht mehr, aber es ändert auch nichts. Sobald DirectX ausgewählt ist und ich den Wert auf 0 setze sehe ich wieder schwarz
Und jedesmal wenn ich den Wert auf 0 setze verschwindet der Eintrag NewGfXCfg und ich muss Ihn manuell wieder erstellen
Ist es eigendlich egal ob man wenn man ne 0 setzt Hexadezimal oder Dezimal hat? Eigendlich schon oder?

Teste mal bitte Folgendes:
- Rechtsklick auf den Desktop -> Bildschirmauflösung -> Erweiterte Einstellungen -> Tab Grafikkarte -> Alle Modi auflisten
- Dann den Eintrag 1920 x 1080, True Color (32-Bit), XX Hertz auswählen, wobei XX der Wert ist, der 85 am nächsten ist, OK, Übernehmen
- 15 Sekunden warten, Abbrechen, Abbrechen
- Blieb der Bildschirm während der 15 Sekunden schwarz?

1920x1080 True Color (32-bit) 60 Hertz ist der Höchste Wert in richtung 85 und ist schon standartmäßig ausgewählt gewesen.
Es passierte folglich nichts, also hab ich das nochmal mit 59 Hertz getestet und der Bildschirm blieb nur 1-2 Sekunden schwarz.

> Und jedesmal wenn ich den Wert auf 0 setze verschwindet der Eintrag NewGfXCfg und ich muss Ihn manuell wieder erstellen


Wenn die Aufloesung auf 0 steht, detektiert Clonk das als kaputte Registry und setzt die gesamte Konfiguration zurueck.

Ansonsten keine Ahnung, was bei dir falsch laeuft. Musst du wohl im Fenster spielen.